Home / Articles / Email / ASP.NET 2.0.50727.0 event id 1310

ASP.NET 2.0.50727.0 event id 1310

we saw the following error at a client with exchange 2010 sp3 and the latest rollup as of 11/1/15:

 

we are seeing the following error in event viewer and outlook clients are having issues with setting out of office messages.

Log Name:      Application
Source:        ASP.NET 2.0.50727.0
Date:          11/1/2015 5:45:42 PM
Event ID:      1310
Task Category: Web Event
Level:         Warning
Keywords:      Classic
User:          N/A
Description:
Event code: 3008
Event message: A configuration error has occurred.
Event time: 11/1/2015 5:45:42 PM
Event time (UTC): 11/2/2015 12:45:42 AM
Event ID: 6b6f02c14ea24eefac13b7c265b77fa5
Event sequence: 1
Event occurrence: 1
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/1/ROOT/Autodiscover-128-130908987428796236
Trust level: Full
Application Virtual Path: /Autodiscover
Application Path: C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Autodiscover\
Machine name: server

Process information:
Process ID: 4856
Process name: w3wp.exe
Account name: NT AUTHORITY\SYSTEM

Exception information:
Exception type: HttpException
Exception message: Could not load file or assembly ‘Microsoft.Exchange.Security, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ or one of its dependencies. The system cannot find the file specified. (C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Autodiscover\web.config line 940)

Request information:
Request URL: https://mail.contoso.com:443/autodiscover/autodiscover.xml
Request path: /autodiscover/autodiscover.xml
User host address: 1.1.1.1
User:
Is authenticated: False
Authentication Type:
Thread account name: NT AUTHORITY\SYSTEM

Thread information:
Thread ID: 1
Thread account name: NT AUTHORITY\SYSTEM
Is impersonating: False
Stack trace:    at System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)

Custom event details:

Event Xml:
<Event xmlns=”http://schemas.microsoft.com/win/2004/08/events/event”>
<System>
<Provider Name=”ASP.NET 2.0.50727.0″ />
<EventID Qualifiers=”32768″>1310</EventID>
<Level>3</Level>
<Task>3</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime=”2015-11-02T00:45:42.000000000Z” />
<EventRecordID>1199236</EventRecordID>
<Channel>Application</Channel>
<Computer>server.contoso</Computer>
<Security />
</System>
<EventData>
<Data>3008</Data>
<Data>A configuration error has occurred.</Data>
<Data>11/1/2015 5:45:42 PM</Data>
<Data>11/2/2015 12:45:42 AM</Data>
<Data>6b6f02c14ea24eefac13b7c265b77fa5</Data>
<Data>1</Data>
<Data>1</Data>
<Data>0</Data>
<Data>/LM/W3SVC/1/ROOT/Autodiscover-128-130908987428796236</Data>
<Data>Full</Data>
<Data>/Autodiscover</Data>
<Data>C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Autodiscover\</Data>
<Data>server</Data>
<Data>
</Data>
<Data>4856</Data>
<Data>w3wp.exe</Data>
<Data>NT AUTHORITY\SYSTEM</Data>
<Data>HttpException</Data>
<Data>Could not load file or assembly ‘Microsoft.Exchange.Security, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ or one of its dependencies. The system cannot find the file specified. (C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\Autodiscover\web.config line 940)</Data>
<Data>https://mail.contoso.com:443/autodiscover/autodiscover.xml</Data>
<Data>/autodiscover/autodiscover.xml</Data>
<Data>10.15.11.39</Data>
<Data>
</Data>
<Data>False</Data>
<Data>
</Data>
<Data>NT AUTHORITY\SYSTEM</Data>
<Data>1</Data>
<Data>NT AUTHORITY\SYSTEM</Data>
<Data>False</Data>
<Data>   at System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)
</Data>
</EventData>
</Event>

when i ran

test-outlookwebservices -identity email@contoso.com i get this:

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1019
Type       : Information
Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://ma
il.contoso.com/autodiscover/autodiscover.xml.

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1013
Type       : Error
Message    : When contacting https://mail.contoso.com/autodiscover/autodiscover.xml received the error The remote server
returned an error: (500) Internal Server Error.

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1023
Type       : Error
Message    : The Autodiscover service couldn’t be contacted.

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1104
Type       : Error
Message    : The certificate for the URL https://server.domain/autodiscover/autodiscover.xml is incorrect. For SSL t
o work, the certificate needs to have a subject of server.domain, but the subject that was found is mai
l.contoso.com. Consider correcting service discovery, or installing a correct SSL certificate.

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1113
Type       : Error
Message    : When contacting https://server.domain:443/autodiscover/autodiscover.xml received the error The remote s
erver returned an error: (500) Internal Server Error.

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1123
Type       : Error
Message    : The Autodiscover service couldn’t be contacted.

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1024
Type       : Success
Message    : [EXCH] Successfully contacted the AS service at https://mail.contoso.com/ews/exchange.asmx. The elapsed time
was 671 milliseconds.

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1026
Type       : Success
Message    : [EXCH] Successfully contacted the UM service at https://mail.contoso.com/ews/exchange.asmx. The elapsed time
was 15 milliseconds.

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1124
Type       : Success
Message    : [Server] Successfully contacted the AS service at https://server.domain/ews/exchange.asmx. The elapsed
time was 31 milliseconds.

RunspaceId : ac363535-bb72-40e1-af08-b97438790ba5
Id         : 1126
Type       : Success
Message    : [Server] Successfully contacted the UM service at https://server.domain/ews/exchange.asmx. The elapsed
time was 15 milliseconds.

 

To resolve this use absolute paths in the web.conf file.  you can reference this article:

 

https://exchangeranger.wordpress.com/2015/06/12/exchange-2013-cu8-application-event-warning-1310-microsoft-exchange-security-assembly/

 

certain places on the web will tell you to change the path to:

C:\Program Files\Microsoft\Exchange\V14\bin\

that didnt work for us as ours was:

 

c:\program files\microsoft\exchange server\v14

 

keep this in mind will troubleshooting your issue

 

Share


Comment on ASP.NET 2.0.50727.0 event id 1310

Leave a Reply






Contact Us